Page 1 of 1

DescribeCityProductionCalculation tax rate zero bug

Posted: Sun May 27, 2007 10:34 pm
by Lupinedreams
Error message when clicking on starting town reads:

DescribeCityProductionCalculation: Production, Consumption, Percentage and Cap were all zero (RE03)

Only one player out of three had such a bug. This is the first game we have tried so far. Will try to reproduce it.

This effectively locks this player out of the game as it stops them from being able to use their initial town...they canonly use their starting spearmen and swordsmen from then on.

Posted: Mon May 28, 2007 12:55 am
by Implode
Weird, RE03 = Gold... I can imagine getting a message like that if you intentionally set your tax rate as zero and sold all your buildings (so you were producing & using zero gold per turn)... but I don't see how it could happen under normal circumstances. Let me know if you manage to get it again...

Posted: Tue May 29, 2007 11:22 am
by Implode
Thanks to Virm for confirming my suspicion that the "DescribeCityProductionCalculation" bug was due to setting the tax rate at zero, I tried this and got the error myself too. I'll get this fixed in the next version.

Posted: Tue Sep 18, 2007 1:56 am
by Implode
Fixed in 0.9.2