Game crashes always

Place to report bugs in MoM IME and suggest ideas for enhancements (please read rules before posting)
Post Reply
sticktrick
Posts: 3
Joined: Sat Jul 19, 2008 2:41 pm

Game crashes always

Post by sticktrick » Sat Jul 19, 2008 3:11 pm

Every time I played MoM via LAN (via Hamachi!) it crashes after 2-7 turns...
The error message is:

TNDGThreadLock.Lock: TfrmMomClient.frmNewTurnMessagesParchmentMeasureItem (MMM) requested lock with sequence 12 but this thread already has later lock sequence 102 locked

I run on VISTA 64, but it also happens on XP as well...

Can someone help me???

User avatar
Implode
Site Admin
Posts: 432
Joined: Fri Feb 24, 2006 3:35 am
Location: Newfoundland, Canada
Contact:

Re: Game crashes always

Post by Implode » Sun Jul 20, 2008 12:02 am

Do you know if there's something you're always doing at about that point? Finishing constructing a particular unit or building? Casting some spell that you always cast at the start of the game? It would help me immensely in trying to find the bug. Even better, download the debug version and see if you can get that to crash, and if so email me the log file it produces and I'll see if I can fix it.

Thanks for reporting it though!

Implode.

User avatar
Implode
Site Admin
Posts: 432
Joined: Fri Feb 24, 2006 3:35 am
Location: Newfoundland, Canada
Contact:

Re: Game crashes always

Post by Implode » Mon Jul 21, 2008 3:34 pm

Thanks for emailing me the log files, they gave me enough hints as to the cause - initiating a combat in a simultaneous turns game. Have made a 0.9.3.1 to fix this, on the Downloads page. You will have to uninstall 0.9.3 before installing 0.9.3.1 (the installer I use will update major versions like 0.9.2 -> 0.9.3, but not minor versions).

Its a bit of a major bug, so sorry I missed it when testing 0.9.3. I'd just been working on 0.9.3 for so long I didn't want to delay it any further so rushed it out without doing too much testing. I'm surprised nobody has ran into this before now - they must all be playing one-at-a-time turns games (which weren't affected by the bug)!

Implode.

sticktrick
Posts: 3
Joined: Sat Jul 19, 2008 2:41 pm

Re: Game crashes always

Post by sticktrick » Mon Jul 21, 2008 6:53 pm

Thanks for the bugfix!
Now we can enter a fight BUT we are waiting on each others fight vs AI (it happens if both players make a fight in the same turn).

I'll send the log-files ;)

Sticktrick

User avatar
Implode
Site Admin
Posts: 432
Joined: Fri Feb 24, 2006 3:35 am
Location: Newfoundland, Canada
Contact:

Re: Game crashes always

Post by Implode » Tue Jul 22, 2008 1:10 am

sticktrick wrote:we are waiting on each others fight vs AI (it happens if both players make a fight in the same turn)
Ok you'll have to help me out a bit here, because I just tried it and I can't reproduce what you're saying, and the log files don't have any errors in them (which I'm not surprised at, since it sounds like you're saying the game just gets stuck waiting for something to happen, you don't see an actual error message?)

What I did was:
    Loaded up server + client on one PC
    Started game, 1 human opponent, large map, powerful nodes, imposs difficulty, *simultaneous turns*, used the debug option to turn off FOW
    Joined game from other PC
    Set both players to attack a lair exactly 2 squares away
    First turn they both hit Next Turn and move there
    Second turn they both hit Next Turn
    Both players see the scheduled combat scroll, with a line saying "your 2 units scouted a lair containing blah blah", the second line says "Other players have 1 combats to play"
    When I play the combat of one of the players, on the other PC I can see their scroll change to say "Other players have 0 combats to play"
    When both combats are over, scrolls disappear and next turn starts

Are you doing something different to the above? The fact that you're finding these things make me think I should be asking for volunteers to be beta testers as 0.9.4 starts to be playable (it isn't yet) :)
Thanks,

Implode.

sticktrick
Posts: 3
Joined: Sat Jul 19, 2008 2:41 pm

Re: Game crashes always

Post by sticktrick » Tue Jul 22, 2008 5:50 pm

We do the same stuff...
I'll send you both screenshots! form my side (server) and from a friend of mine (client)

The scrolls won't go away...

hope this helps
Sticktrick

Post Reply