Client performance / frame rate

Polls asking for feedback/suggestions for MoM IME
Post Reply

What frame rate per second (fps) do you get with the MoM IME client on your PC?

50+ fps
5
45%
40-49 fps
0
No votes
30-39 fps
2
18%
25-29 fps
1
9%
20-24 fps
0
No votes
15-19 fps
2
18%
12-14 fps
0
No votes
11 fps or lower
1
9%
 
Total votes: 11

User avatar
Implode
Site Admin
Posts: 432
Joined: Fri Feb 24, 2006 3:35 am
Location: Newfoundland, Canada
Contact:

Client performance / frame rate

Post by Implode » Wed Jan 10, 2007 2:28 am

A few people have posted with machine specs and saying the client runs really slowly. In 0.9.0 you can now tick an option on the Options screen to display the frame rate, so we can now get decent measurable speeds. So thought it would be interesting for folks to check what frame rate they get and post the results and their machine specs here.

After creating a game and going into the map screen, hit Patrol for both your starting units. The greying out of the map to show where units can/cannot move slows the client down somewhat so you want to take measurements without this. Simiarly, pick a spell to research or set your research slider on the Magic screen to zero, to get rid of the book icon from the next turn button. Then scroll around the map and see what frame rates you get. Frame rate can vary slightly depending what portion of the map you're looking at (depending on how many mines/cities/units you can currently see).

What I got on my 3 PCs was:

Model: Clevo D470W
CPU: 3.06 GHz Intel Pentium 4 with hyper-threading
Motherboard: N/A (laptop)
Graphics: 64 MB ATI Radeon Mobility 9000
RAM: 1 GB
Desktop resolution: 1920 x 1200 x 32 bit
Operating system: Windows XP 32 bit
MoM IME client frame rate with 0.9.0: 33-37 fps (drops to 30-35 fps if I switch to 16 bit colours)

Model: Custom built
CPU: 1.8 GHz AMD Athlon 64 3000+
Motherboard: Asus A8N-E
Graphics: 512 MB NVidia GeForce 7900 GTX Overclocked
RAM: 768 MB
Desktop resolution: 1920 x 1200 x 32 bit
Operating system: Windows 2000 32 bit (now moved to Windows XP 64 bit - frame rate is exactly the same whether I run in a 32 bit O/S or run in WoW64 in a 64 bit O/S)
MoM IME client frame rate with 0.9.0: 27-30 fps (drops to 24-27 fps if I switch to 16 bit colours)

Model: Dell Dimension 8100
CPU: 1.5 GHz Intel Pentium 4
Motherboard: Whatever it came with :) The motherboard isn't listed on the spec sheet
Graphics: 64 MB NVidia GeForce 2 Ultra
RAM: 512 MB
Desktop resolution: 1152 x 864 x 32 bit
Operating system: Windows XP 32 bit
MoM IME client frame rate with 0.9.0: 15-17 fps

So at least from my own tests, it looks very much like the speed is more to do with what speed your CPU is than how good your graphics card is. It'll be interesting to see what other people report.

Edit: Turning map smoothing on/off doesn't affect the frame rate since it still has just as much to draw. I didn't put the option there for folks with low frame rates, I put it there a) to help me debug what was going on when the map smoothing wasn't working right, and b) because its interesting and sometimes gives me ideas to see the map how the server sees it.

Implode.
Last edited by Implode on Sat Jan 27, 2007 3:28 am, edited 2 times in total.

hammer
Posts: 9
Joined: Sat Jan 06, 2007 1:46 pm

Post by hammer » Wed Jan 10, 2007 1:24 pm

Here are my results:
- without map smoothing - 17 fps avg
- with map smoothing 18 fps avg
- when moving units - 11 fps avg
not very good i might say :)
------------

My system configuration is:
CPU: Amd 2200+ Mhz
RAM: 1024 MB DDR 400 Mhz
VIDEO: Ati RADEON 9250 256 MB
MB: Asus NForce 2 deluxe
Resolution: 1152x864 x 32 bpp
OS: Windows XP 32bit SP2

akq
Posts: 3
Joined: Sat Jun 16, 2007 11:04 am

Post by akq » Sat Jun 16, 2007 2:27 pm

Its not that the FPS would be low, in my case, but the game is like, made to be slow :O

Like, All the menu's and unit moving is coming up slow, even if FPS is 60.
In original MoM you can easily make several citys build their buildings or units, but in this, it takes so much time to bring the menus.
Units are too moving very slowly in map..

Edit:
Ill take it back. Even that units and everything else doing slow, FPS usually at the beginning of turn is 0,1 - 1,2 :F

Nehan
Posts: 32
Joined: Mon Jun 02, 2008 11:06 am

Re: Client performance / frame rate

Post by Nehan » Mon Jun 09, 2008 1:22 pm

My results:
Athlon 3200+
Geforce 6600 something
740 mb ram
12sthx1048 resolution
windows xp

frame rate varies from 30 to 60 fps
Warsaw isn't a kind of a battle saw. It's the capital of Poland.

Post Reply